TIE Aggressor

This is the place for chit chat! Everything goes even Star Trek! Just make sure to buy the Moderator a drink!

Moderators: K_Kinnison, Darksaber, General_Trageton

Post Reply

TIE Aggressor

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Sat Mar 10, 2018 6:15 am

Screenshot 2018-03-04 13.39.33.png
Screenshot 2018-03-04 13.39.33.png (714.5 KiB) Viewed 976 times
Like most Imperial fighters, the Aggressor sported a small profile, making it a difficult target to hit. Its maneuverability suffered however, as what limited space was available was needed to provide additional power for the turret. In addition, as the turret needed extra firing space around the sides of the ship to line up shots, the Aggressor had a distinct shortage of ionization and radiation paneling in comparison to most TIE fighters. Because of this shortage of space, the standard TIE cockpit pod used for the Aggressor was lacking its usual chin-mounted weapon hardpoints, instead utilizing external racks for modular forward-facing laser cannons.

Download

The ship seems to be required to be classed as a light transport for the turret to work, in the event you can't find it in the shiplist under "fighters", this is why.
Last edited by Driftwood on Sat Mar 10, 2018 4:28 pm, edited 1 time in total.

User avatar
Jaeven
Ensign
Galactic Empire
Posts: 262
Joined: Mon Mar 30, 2015 3:18 am

Post by Jaeven » Sat Mar 10, 2018 1:05 pm

Urgh, I remember how annoying these were in SWG. Such a pain in the ass to kill, especially the higher tier ones.

Great opt though :D

Any potential upcoming love for the TIE Oppressor? ;)

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 9411
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Sat Mar 10, 2018 1:31 pm

Recreated the TIE Aggressor and TIE Oppressor years ago, but never got around to finishing them haven't touched either since 2011
TieAgg.jpg
TIE Aggressor
TieAgg.jpg (68.81 KiB) Viewed 950 times
TieOpp.jpg
TIE Oppressor
TieOpp.jpg (95.48 KiB) Viewed 950 times
Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Sat Mar 10, 2018 2:49 pm

I've always liked your textures.

Maybe we'll see another version of this ship from you in the future? :p

And Jaeven, yes I'll be porting over the oppressor soon, right after I finish the three Hutt fighters I've been working on getting ported the last couple weeks.
Last edited by Driftwood on Sat Mar 10, 2018 4:25 pm, edited 1 time in total.

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 9411
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Sat Mar 10, 2018 3:46 pm

Driftwood wrote:
Sat Mar 10, 2018 2:49 pm
I've always liked your textures.

Maybe we'll see another version of this ship from you in the future? :p
Thanks, I couldn't have adapted to making the textures without Decoy's help, who originally made the default Tie textures :) just followed on from what he did :)

One day we'll see about finishing it, but it won't be any time soon so the floor is yours :D
Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Sat Mar 10, 2018 4:02 pm

File has been updated with .shp

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 9411
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Sat Mar 10, 2018 7:08 pm

Have you uploaded the right file, just download the Tie again, but no .shp file :(
Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Sat Mar 10, 2018 8:35 pm

That's weird, I'll re-upload again.

Should be good now.

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 9411
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Sat Mar 10, 2018 9:04 pm

Yep all's good :)
Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

JeremyaFr
Lieutenant
XWAU Member
Posts: 818
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun Mar 11, 2018 9:08 am

Nice. :thumbs:

User avatar
Mark_Farlander
Cadet 1st Class
Rebel Alliance
Posts: 230
Joined: Tue Jan 16, 2018 10:47 pm

Post by Mark_Farlander » Sun Mar 11, 2018 11:17 am

Magnificent work!

By the way, was the TIE/AG Aggressor starfighter commissioned before the TIE/IN interceptor according to the Legends continuity?

User avatar
Jaeven
Ensign
Galactic Empire
Posts: 262
Joined: Mon Mar 30, 2015 3:18 am

Post by Jaeven » Sun Mar 11, 2018 2:26 pm

No. TIE Interceptor entered service well before Yavin, whereas the Aggressor was never produced in large numbers at any point. They were still in a preliminarily testing phase after Yavin.

That's all we know, they didn't show up in a lot of material outside of SWG.

XDragon
Cadet 2nd Class
Posts: 54
Joined: Tue Jan 29, 2008 12:01 am
Contact:

Post by XDragon » Tue Mar 13, 2018 4:18 pm

Is there anyway to add the turret to the ship?

Also, in skirmish, I noticed there were no sounds with the laters
Glory to the Empire

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Tue Mar 13, 2018 4:42 pm

No laser sound? That's a new one, I can't say I've experienced that, but will look into it.

Are you talking about a turret like the corts, or an auto for one? If the latter the ship has to be set as a shuttle rather than fighter.

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 9411
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Tue Mar 13, 2018 7:36 pm

Your kidding lol

@XDragon, Simple solution, plus this is if you either have the XWACP ior DSUCP installed, look in you flightmodels folder you should see a load of text file find the TieFighterSound.txt make a copy of it and rename it TieAggressorSound.txt Laser sound solved.
Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

XDragon
Cadet 2nd Class
Posts: 54
Joined: Tue Jan 29, 2008 12:01 am
Contact:

Post by XDragon » Wed Mar 14, 2018 6:08 pm

So the solution isn't as simple, there's no engine, damage, laser or anything sound in any fighter. It's dscup 2.5, modified with just a few ships and edited stats oh and custom missions. I'm not sure if something got messed up
Glory to the Empire

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 9411
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Wed Mar 14, 2018 7:02 pm

If you have no sound at all, then something got messed up, try reinstalling XWA
Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

XDragon
Cadet 2nd Class
Posts: 54
Joined: Tue Jan 29, 2008 12:01 am
Contact:

Post by XDragon » Wed Mar 14, 2018 7:11 pm

Yeah just the music plays. It's only on this version if the installs too, I checked with the DSCUP and DTM's Unicorn squadron.

I guess lll have to save the pilot and mission and delete the folder and try it again.
Glory to the Empire

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Sat May 26, 2018 5:29 pm

TIE Aggressor cockpit POV has been updated.
Added TIEAggressorSound.txt

Correct POV 1, 0, 0.

Reminder: For the turret to function the craft must be classed as a shuttle, otherwise you will experience oddities with the turret lasers.

User avatar
Phoenix Leader
Cadet 2nd Class
Posts: 79
Joined: Wed Aug 08, 2018 2:20 pm

Post by Phoenix Leader » Fri Aug 10, 2018 7:27 am

With "oddities" do you mean that the turret won't fire?
Or will all the weapons fire from a single point?

User avatar
Driftwood
Lieutenant Commander
XWAU Member
Posts: 1238
Joined: Wed Oct 22, 2003 11:01 pm
Contact:

Post by Driftwood » Tue Sep 04, 2018 11:09 pm

Okay, so there is apparently an issue with the cockpit opt for some reason. I've had two people mention that the cockpits for the Aggressor and the Oppressor eventually crash the game.

I have thus far not been able to replicate this issue myself, and looking at the vertex counts they are all well within 4096 per mesh.

This is a perplexing issue since the exterior files use almost identical cockpit meshes discounting the interior glass supports removed since you can't see them from outside. Thing is, I opted the cockpit before the exterior file and both should be having the same issue, but they're not. Short of starting completely from scratch, I can't fix the issue since I can't figure out what the source of the problem is.

If you experience any crashes, I recommend for the time being, using DS' TIE Fighter cockpit opt and rename it to TIEAggressorcockpit/TIEOppressorcockpit

One individual stated that the game only crashes inside the Hangar, and that inflight the ship works fine.

Post Reply