Random crashes?

Need help with hardware? Game doesn't run? System wont boot? We might be able to help!

Moderators: Darksaber, Forceflow, decoy

Post Reply

Random crashes?

RogueLiter
Recruit
Posts: 4
Joined: Sat Apr 28, 2007 11:01 pm

Post by RogueLiter » Mon Oct 14, 2019 10:58 pm

I haven't played much since the GoG launch, and I've gotten a HOTAS between now and then, so over the weekend I did a fresh install and tried to start a new campaign. I downloaded the newest version of Darksaber's pack, all the XWAUpgrade packs more recent then that, and the new DDraw. I even spend a considerable amount of time putting a TARGET profile together for it. Overall, the game runs fantastic, but I'm frustrated by these random crashes after missions. It only happen about 50% of the time, but when it does happen the game will die right after hitting the debrief, or when entering the hangar after a mission. Has anyone else seen this issue before?

If it helps, I'm running Win10 64, with an i7, 16GB of memory and 2x GTX 980s. It's an older machine, sir. But it checks out.

blue_max
Ensign
XWAU Member
Posts: 317
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Tue Oct 15, 2019 9:15 pm

Can you attach a crash report? The game may also have create a dump file under %localappdata%\crashdumps, is there anything there?

You mentioned the new DDraw, do these crashes happen with a different version of this library?

RogueLiter
Recruit
Posts: 4
Joined: Sat Apr 28, 2007 11:01 pm

Post by RogueLiter » Wed Oct 16, 2019 1:10 am

Okay, I found the dumps. They were too big to attach? So I made a google link here.

https://drive.google.com/file/d/1u7ayRK ... sp=sharing

blue_max
Ensign
XWAU Member
Posts: 317
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Wed Oct 16, 2019 5:38 am

Alright, these are the error messages from both crash dumps:

Unhandled exception at 0x004D332D (XWingAlliance.exe) in XwingAlliance.exe.7552.dmp: 0xC0000005: Access violation writing location 0x70A14DB0.

Unhandled exception at 0x004D332D (XWingAlliance.exe) in XwingAlliance.exe.11084.dmp: 0xC0000005: Access violation writing location 0x6CD86998.

and they both crashed in XWA:

> XWingAlliance.exe!004d332d() Unknown

The function seems to be Flight_RenderRectangle16 and it crashed while it was doing the following (this is location 0x004d332d):

*(v16 - 2) = g_FlightPalette16Table[g_Flight_DrawColorIndex];

So the problem is probably not related to ddraw.dll, although I encourage you to try other versions of ddraw to see if it still happens.
Unfortunately, I'm not familiar with this area; but maybe others might be able to help.

Other information that can help us is what resolution are you running? Do you have hook_32bpp.dll in your install path? Does it always happen on the same spot? Does it happen with any version of ddraw?

JeremyaFr
Lieutenant Commander
XWAU Member
Posts: 1600
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Wed Oct 16, 2019 3:53 pm

Hello,
I think that the crash may come from the res1200 hook. There was a similar crash.
Can you try with all the up to date hooks (using XWA Hooks Setup).

RogueLiter
Recruit
Posts: 4
Joined: Sat Apr 28, 2007 11:01 pm

Post by RogueLiter » Thu Oct 17, 2019 3:24 am

Hey, the hooks seem to have had a positive effect. I played three missions tonight in a row with no crashes. Can't get any further though because I always get stuck on the damn first Y-wing mission, the Assault Shuttle always tears me to bits. I'll give it a few more tries tomorrow as well.

blue_max
Ensign
XWAU Member
Posts: 317
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Oct 17, 2019 4:58 am

RogueLiter wrote:
Thu Oct 17, 2019 3:24 am
Hey, the hooks seem to have had a positive effect. I played three missions tonight in a row with no crashes.
So, for the benefit of others, could you please confirm that disabling the res1200 hook fixed your crashes?

JeremyaFr
Lieutenant Commander
XWAU Member
Posts: 1600
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sat Oct 19, 2019 7:49 pm

He has not disabled the hook. He has installed the updated version.

Pqs_net
Cadet 4th Class
Posts: 12
Joined: Sun Nov 29, 2009 9:45 pm

Post by Pqs_net » Sat Nov 09, 2019 3:06 pm

Hi everyone...
I too got problems with crashes in the new XWAU 1.60 version...
Im sorry for the long text, but i feel i have to explain a bit.

I just recently updated to the 1.60 XWAU version.
Before i had the XWAU 1.30 version, and it was flawless.
I now have uninstalled the XWAU V.160 and installed the XWAU V1.30 again, with no problems.


Problems i have in XWAU V1.60

1. Game Crash when loading a mission.
Some missions wont load/crash when in the loading screen. There are no error messages, the game just exit and shut down.
This happens on several missions, but i here take the Death Star missions 1b7m1w and 1b7m2w as an example...

I dont know how to open dumpfiles but have linked them on my google drive: https://drive.google.com/open?id=1NV8HV ... EjvxzT7XcH

2. Lacking of Textures and OPT.
When uninstalling the XWAUP V.160 (The uninstaller backs up old files by default) the missions wont crash when loading.
However.... when being in the hangar the Falcon cockpit and hangar it self isnt there in the Deathstar Misisons and some other mission maps.
Its just the basic Starfield (almost black) and the Hud interface with menu where you choose warheads and countermeasires that is visible.

As i said above, if i reinstalling the XWAU v.1.30 everything works as normal again.
This makes med pretty sure that the XWAU 1.60 is where the problem lies.

3. Earlier edited mission files cause crash.
I have also another question related to the XWAU 1.60 version about edited missions files (.tie) from previous versions...
If i have an old edited missions file from v 1.30 or earlier, and copy them into missions folder it seems these .tie files dont work with the 1.60 version.
The game crash the same way as earlier described...
These files works with all earlier versions of X-wing Alliance and XWAU.

I noticed there are a whole lot new files with the XWAU V1.60 such as .ini files in the mission map, and several .text and other files.
Can these ads and changes be the reason old .tie mission files wont work with the XWAU V 1.60?

Thanks in advance for any help i can get.
// PQ

Post Reply