gaps in music and voices

Need help with hardware? Game doesn't run? System wont boot? We might be able to help!

Moderators: Darksaber, Forceflow, decoy

Post Reply

gaps in music and voices

User avatar
WaxSavage
Cadet 4th Class
Posts: 13
Joined: Mon Dec 16, 2019 5:50 pm

Post by WaxSavage » Thu Jan 02, 2020 8:09 pm

Hi techs,

XWA with DSUCP 2.6.

The intro music, movie clip music and in-game music and voice seems to 'hiuccup' as if there are repeated momentary sound gaps. Could there be a gap being created as sound files are called up by the game?
thanks,

Wax
“Some day you will be old enough to start reading fairy tales again.”
― C.S. Lewis

blue_max
Lieutenant JG
XWAU Member
Posts: 562
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Jan 02, 2020 8:12 pm

I believe this happens if you try to run the game on multiple cores. You have to force the game to run on one core only. Also, I think you have to set ProcessAffinity to a specific core in ddraw.cfg (but I'm not sure).

User avatar
Darksaber

Fleet Admiral (Administrator)
Posts: 10423
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Thu Jan 02, 2020 8:20 pm

Yes your correct, by default the DDraw.cfg in both XWAUCP and DSUCP are set to Core 2

Code: Select all

; ProcessAffinityCore = int value
; When set to 0, the process affinity is not changed
; The value indicates the core you want the process to run on
ProcessAffinityCore = 2
Setting this to 1, 3 or 4 may solve your problem, dunno????
“You can please some of the people all of the time, you can please all of the people some of the time, but you can’t please all of the people all of the time”.”
- John Lydgate

Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
keiranhalcyon7
Ensign
Posts: 361
Joined: Tue Jan 02, 2018 6:41 am

Post by keiranhalcyon7 » Thu Jan 02, 2020 11:12 pm

I've also observed cutscene choppiness with the time hook enabled. If setting core affinity doesn't help, try renaming hook_time.dll to something like hook_time.dll.disabled to disable that hook and see if that improves things. (It's annoying, but in order to watch the cutscenes, I exit the game, disable the hook, renter and watch, exit again, enable the hook, them go back and play some more.)

User avatar
WaxSavage
Cadet 4th Class
Posts: 13
Joined: Mon Dec 16, 2019 5:50 pm

Post by WaxSavage » Fri Jan 03, 2020 5:23 pm

Darksaber wrote:
Thu Jan 02, 2020 8:20 pm
Yes your correct, by default the DDraw.cfg in both XWAUCP and DSUCP are set to Core 2

Code: Select all

; ProcessAffinityCore = int value
; When set to 0, the process affinity is not changed
; The value indicates the core you want the process to run on
ProcessAffinityCore = 2
Setting this to 1, 3 or 4 may solve your problem, dunno????
Thank for the responses. I tried changing the ProcessAffinityCore using each of the numbers from 0 ~ 4. No improvement.
Then tried Reimar's DDraw file pack https://github.com/rdoeffinger/xwa_ddra ... 10_rc2.zip
changing the ProcessAffinity to the number 2.

Runs perfectly now. Music and voice is as smooth as silk.
“Some day you will be old enough to start reading fairy tales again.”
― C.S. Lewis

Post Reply