SLAM Hook

A Forum dedicated to the Suggestion, Creation and Editing of XWA Dynamic Link Library Files

Moderators: Darksaber, General_Trageton, Forceflow, DTM, JeremyaFr

Re: SLAM Hook

Rookie_One1
Lieutenant Commander
Rebel Alliance
Posts: 1449
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Wed Feb 13, 2019 7:18 pm

Would that even be possible ?
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

User avatar
keiranhalcyon7
Lieutenant JG
Posts: 531
Joined: Tue Jan 02, 2018 6:41 am

Post by keiranhalcyon7 » Wed Feb 13, 2019 8:41 pm

Probably. The better question is, is it worth the effort? Remember, the system was only designed for & tested with one craft. There are probably all sorts of abusable corner cases when it's enabled it for others.
Last edited by keiranhalcyon7 on Wed Feb 13, 2019 9:37 pm, edited 1 time in total.

Rookie_One1
Lieutenant Commander
Rebel Alliance
Posts: 1449
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Wed Feb 13, 2019 8:44 pm

abusable corners ? what a weird image

*abuse corner*
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

Justagai
Cadet 1st Class
Posts: 214
Joined: Mon Dec 08, 2014 10:59 pm

Post by Justagai » Sun Feb 24, 2019 6:34 am

There seems to be an issue with the hook. If one uses SLAMS during a mission, then quits and refiles, the sound won't play anymore.

In slam.cpp:

Code: Select all

if (hasSlam && !soundsLoaded)
	{
		soundsLoaded = true;
...
		}
The issue here I believe is that the sound isn't checked if it's loaded or not. Removing "!soundsLoaded" fixes the issue, but I'm sure there are better solutions.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2247
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun Feb 24, 2019 11:30 am

Thanks for the bug report.

I've fixed it.

Please redownload xwa_hook_slam.zip

Post Reply