X-Wing Alliance 2020 Mega Patch available NOW!

All the XWAU recent release news from the project can be found here

Re: X-Wing Alliance Mega Patch 2020 available NOW!

PunkFriday
Cadet 4th Class
Posts: 10
Joined: Sun Nov 02, 2014 4:02 pm

Post by PunkFriday » Fri Dec 04, 2020 4:36 pm

amazing guys! point me to where the shipsets are!

Rookie_One1
Rebel Alliance
Posts: 1557
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Fri Dec 04, 2020 4:41 pm

Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

Geoffman72
Recruit
Posts: 8
Joined: Mon Nov 16, 2020 10:50 pm

Post by Geoffman72 » Sat Dec 05, 2020 6:04 pm

DTM wrote:
Thu Dec 03, 2020 2:50 pm
Geoffman72 wrote:
Wed Dec 02, 2020 9:45 pm
Out of curiosity, has anyone else had their loaded pilots experience wiped when re-running Babu Friks configurator? I did a fresh Steam install, installed the megapatch, ran BF's config, played through the second mission after you join the Rebels, then re-ran to config to tweak a bit. Logged back in and was on the first Sabra mission.

Other than this, and a few bugs that seem to have already been caught, it's stunning work on a two decade old game!
This shouldn't happen, because Babu doesn't change the stats or the progress of the pilots ... whatever happened, I rule out that it's Babu's fault ... poor little Babu ...
Just to update on this, might be a Steam thing. I did a fresh wipe/reinstall, played back to where I lost progress and called it a night. Backed up my pilot though. Launched from Steam on accident just now and it wiped my pilot right out of the install directory.

starflame
Cadet 4th Class
Posts: 12
Joined: Tue May 01, 2012 9:23 pm

Post by starflame » Sat Dec 05, 2020 9:57 pm

First thanks for all the hard work. Truly unbelievable to me that this game is being worked on with such passion in 2020.

I've downloaded and installed the game with patch off steam and have a good system to run it. However, I am seeing a jiggling or wobbling of backgrounds and UI in the game that can be really drastic at times. Has anyone else run into this and/or know of a solution or cause?

Unfortunately the game feels barely playable with this jiggling.

Thank you again!

spas79
Recruit
Posts: 8
Joined: Sun Mar 01, 2020 10:46 am

Post by spas79 » Sat Dec 05, 2020 10:53 pm

I don't understand why, but performance is good for me as long as I stay in the hangar. As soon as the YT-1300 comes out of it, the fps goes to single figures.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5393
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sat Dec 05, 2020 10:55 pm

Run the Babu Frik's Configurator and play with graphic settings options.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
iteachvader
Cadet 2nd Class
Posts: 53
Joined: Thu Feb 28, 2013 4:16 am

Post by iteachvader » Sun Dec 06, 2020 1:37 am

starflame wrote:
Sat Dec 05, 2020 9:57 pm
First thanks for all the hard work. Truly unbelievable to me that this game is being worked on with such passion in 2020.

I've downloaded and installed the game with patch off steam and have a good system to run it. However, I am seeing a jiggling or wobbling of backgrounds and UI in the game that can be really drastic at times. Has anyone else run into this and/or know of a solution or cause?

Unfortunately the game feels barely playable with this jiggling.

Thank you again!
I have this exact same issue with my game as well, with the GOG version. It doesn't seem to correctly accept joystick inputs; I move the joystick slightly to the left, it moves left but also drifts upwards or downwards, even if I'm not giving it any other input. It makes it difficult to aim properly as the background and/or your orientation drifts and jumps around. Minute adjustments are nearly impossible, so it's hard to pinpoint your aim now. It happens when small movements are enabled and disabled with the joystick configurator.

I also noticed that it affects forward movement as well. Sometimes when flying a mission, the fighter drifts in an odd direction instead of moving straight forwards. It makes it very difficult to fly the Death Star tunnel run. A great example is right after the speed boost between the containers, as the fighter stops on a dime and accelerates forwards, but also drifts downwards and to the left. I double and triple checked to ensure it wasn't my joystick, and my joystick is working fine. It's something with the XWAUP2020 pack. I didn't get this issue with previous versions of the pack.

A completely unrelated issue, I wonder if there's any way to disable the speed line effect when Blue Max's effects are enabled. I love the new lighting effects, but with the speed lines being tied to frame rate, they sometimes fly by waaaaay too fast when nothing is on the screen and I'm not moving very fast (even with my monitor locked to 60 FPS). I kinda want to disable them.

And is there any way at all to fix those little spots in the background that always push your reticle away, present in vanilla XWA??? Just a thought.
(The XWAUP team has really outdone themselves with this pack regardless! You guys are awesome!!)
The ability to create 3D models is insignificant next to the power of the Force.

spas79
Recruit
Posts: 8
Joined: Sun Mar 01, 2020 10:46 am

Post by spas79 » Sun Dec 06, 2020 5:16 am

Ace Antilles wrote:
Sat Dec 05, 2020 10:55 pm
Run the Babu Frik's Configurator and play with graphic settings options.
I have tried doing that, but
1) I don't think the system is insufficient to run XWAUP to the max, we're talking a 5GHz 9700k, 2080ti, 64Gb 3200MHz RAM... should be beefy enough.
2) whatever option I change, it seems that nothing changes
3) (Unrelated) seems like there's no way to make it "see" the throttle (I'm using a separate throttle)

User avatar
JaggedFel
Galactic Empire
Posts: 301
Joined: Wed Sep 06, 2006 11:01 pm
Contact:

Post by JaggedFel » Sun Dec 06, 2020 1:33 pm

spas79 wrote:
Sun Dec 06, 2020 5:16 am
3) (Unrelated) seems like there's no way to make it "see" the throttle (I'm using a separate throttle)
For that you'll either need to use vjoy, or configure the joystick hook. XWA by itself cannot use multiple devices. Personally, I use vjoy to combine the T16000M, as I also run TIE and the rest of the series.
Ye Olde Galactic Empire Mission Editor v1.9.1
Current software WIPs: TIE Layout and Cutscene Editor, TIE/XvT Cockpit Editor
Libraries / Format specs: *.tie, *.plt, *.tfr, *.lfd , *.act, *.dat image files, *.fnt

PunkFriday
Cadet 4th Class
Posts: 10
Joined: Sun Nov 02, 2014 4:02 pm

Post by PunkFriday » Sun Dec 06, 2020 3:02 pm

Regarding shipsets, what about all the other ships from the now defunct Ultimate Craft Pack? Where can I find those? thanks for all your hard work everyone.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5393
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Dec 06, 2020 3:28 pm

Just posted a a fix for Battle 2 Mission 1. It will be included in later updates too.
See the Known Issues post.
https://www.xwaupgrade.com/phpBB3/viewt ... 34&t=13106
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5393
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Dec 06, 2020 3:35 pm

iteachvader wrote:
Sun Dec 06, 2020 1:37 am
A completely unrelated issue, I wonder if there's any way to disable the speed line effect when Blue Max's effects are enabled. I love the new lighting effects, but with the speed lines being tied to frame rate, they sometimes fly by waaaaay too fast when nothing is on the screen and I'm not moving very fast (even with my monitor locked to 60 FPS). I kinda want to disable them.
Backup and then open SSAO.CFG
Under Speed Effect
Set enable_speed_shader = 0
That should do it. You can tweak options too.
iteachvader wrote:
Sun Dec 06, 2020 1:37 am
And is there any way at all to fix those little spots in the background that always push your reticle away, present in vanilla XWA??? Just a thought.
Not completely so far. It is a pain for sure
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

kr1z
Cadet 2nd Class
Posts: 82
Joined: Sat Oct 20, 2001 11:01 pm
Contact:

Post by kr1z » Mon Dec 07, 2020 6:45 pm

Thanks again guys :)

Blazingfirestorm
Cadet 2nd Class
Posts: 91
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Tue Dec 08, 2020 2:36 am

I really do like the changes to Battle 0 mission 8 the Y-wing training mission in the last region with the convoy having only assault shuttles was brutal

User avatar
iteachvader
Cadet 2nd Class
Posts: 53
Joined: Thu Feb 28, 2013 4:16 am

Post by iteachvader » Wed Dec 09, 2020 5:01 am

Is there any sort of fix for the jiggly aiming and background/fighter drifting?
The ability to create 3D models is insignificant next to the power of the Force.

Michal
Cadet 1st Class
Posts: 158
Joined: Sun May 05, 2002 11:01 pm
Contact:

Post by Michal » Wed Dec 09, 2020 8:07 pm

Congratulations and thanks to the whole team.
It is a great achievement!
My current project X-Wing Game Series Twitter
My old project X-Wing Series Site, still online

bender
Recruit
Posts: 1
Joined: Sun Dec 13, 2020 9:29 am

Post by bender » Sun Dec 13, 2020 9:34 am

Hello, it's seems to be a wonderfull job but i cant' download the megapatch because ma antivirus said it's infected by Trojan:Win32/CryptInject!ml.

Are you aware of this issue?

User avatar
Forceflow
Fleet Admiral (Administrator)
Posts: 6357
Joined: Wed Oct 20, 1999 11:01 pm
Contact:

Post by Forceflow » Sun Dec 13, 2020 9:44 am

bender wrote:
Sun Dec 13, 2020 9:34 am
Hello, it's seems to be a wonderfull job but i cant' download the megapatch because ma antivirus said it's infected by Trojan:Win32/CryptInject!ml.

Are you aware of this issue?
Please read the jump page of the downloads where you need to acknowledge the disclaimer:
Our installers can trigger false positive results in some virus security software.
There is nothing we can do about this but be assured that we thoroughly test all installers before releasing.
Murphy was an optimist! I am a pessimist!
And always remember that a smile is cheaper than a bullet! (District 9)
Webmaster of the X-Wing Alliance Upgrade Project

User avatar
JaggedFel
Galactic Empire
Posts: 301
Joined: Wed Sep 06, 2006 11:01 pm
Contact:

Post by JaggedFel » Sun Dec 13, 2020 3:22 pm

Was fixing the SuperBackdrops detection in YOGEME, noticed that the Mega Patch says SBD is 3.1, but the readme included is for 3.0. I'm fine either way, just figured I'd point that out.
Ye Olde Galactic Empire Mission Editor v1.9.1
Current software WIPs: TIE Layout and Cutscene Editor, TIE/XvT Cockpit Editor
Libraries / Format specs: *.tie, *.plt, *.tfr, *.lfd , *.act, *.dat image files, *.fnt

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5393
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Dec 13, 2020 3:24 pm

JaggedFel wrote:
Sun Dec 13, 2020 3:22 pm
Was fixing the SuperBackdrops detection in YOGEME, noticed that the Mega Patch says SBD is 3.1, but the readme included is for 3.0. I'm fine either way, just figured I'd point that out.
There's a PDF under Readme\Upgrades
Thanks for pointing it out though. I had already recently spotted that and the Readme files will be cleaned up soon
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Post Reply