X-Wing Alliance 2020 Mega Patch available NOW!

All the XWAU recent release news from the project can be found here

Re: X-Wing Alliance Mega Patch 2020 available NOW!

User avatar
DarHan
Rebel Alliance
Posts: 288
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Sun Nov 29, 2020 11:32 am

I’ve taken advantage of this release to reinstall everything and restart the campaign from scratch. Wheee!
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

User avatar
JeremyaFr
XWAU Member
Posts: 2985
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun Nov 29, 2020 4:52 pm

Ace Antilles wrote:
Sat Nov 28, 2020 1:47 am
Red_Leader wrote:
Fri Nov 27, 2020 11:06 pm
in Endor mission 3, the S-foils on Wedge's X-wing never opened. I watched him for about 2 minutes and they stayed closed.
Anyone have those issues?
So I fixed the Endor bug. It's to do with the Shuttle! I don't know why. Something to do with the weird mission parameters maybe.
I had disabled the Shuttle in missions 2 and 3. Seems fine in 2 but not 3. Bizarre.

So open the 1b7m3w.ini in notepad and just change this

Code: Select all

LoadShuttle = 0
to 1 and it fixes it.
We have pushed the Hangar options a long way so who knows. Thanks for the bug report. We will fix that in our first patch.
This is caused by a bug in the hangars hook.
I've fixed it.
Please redownload the hangars hook.

User avatar
JeremyaFr
XWAU Member
Posts: 2985
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun Nov 29, 2020 4:57 pm

BUG REPORT

In battle 7 mission 3, Red 1 appears in blue in the CMD instead of green.

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5447
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Nov 29, 2020 5:05 pm

JeremyaFr wrote:
Sun Nov 29, 2020 4:57 pm
BUG REPORT

In battle 7 mission 3, Red 1 appears in blue in the CMD instead of green.
This is not a Mission bug as the mission is fine.
This is a Wireframe issue for some reason to do with Blue Max effects.

Thanks for the Hook update that fixed the Shuttle issue :)
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Red_Leader
Rebel Alliance
Posts: 406
Joined: Fri Mar 08, 2002 12:01 am
Contact:

Post by Red_Leader » Sun Nov 29, 2020 5:27 pm

Are we posting bug reports in here? If not I apologize but seeing a few were posted in here, I noticed the Outrider has an ion cannon.
"I want my sanity back." - Wedge Antilles
https://www.freewebs.com/redleaderxwa/

Rookie_One1
Rebel Alliance
Posts: 1558
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Sun Nov 29, 2020 7:30 pm

And turrets don't work on it....hmm
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5447
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Nov 29, 2020 8:13 pm

Red_Leader wrote:
Sun Nov 29, 2020 5:27 pm
Are we posting bug reports in here? If not I apologize but seeing a few were posted in here, I noticed the Outrider has an ion cannon.
Rookie_One1 wrote:
Sun Nov 29, 2020 7:30 pm
And turrets don't work on it....hmm
Neither are bugs. DTM can discuss more on those as it's his ship.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5447
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Nov 29, 2020 8:18 pm

We have posted a small Day 1 fix for the few critical issues.
You can find it on the Download page.


Future bug fixes will be sorted if found at a later date.
If you have any installation issues then please read back on this topic to see if it has been answered.
Otherwise please post in the Bug / Help section
viewforum.php?f=10
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
DTM
Fleet Admiral (Administrator)
Posts: 1904
Joined: Tue Apr 22, 2003 11:01 pm
Contact:

Post by DTM » Sun Nov 29, 2020 8:24 pm

Rookie_One1 wrote:
Sun Nov 29, 2020 7:30 pm
And turrets don't work on it....hmm
The Outrider does not have turrets. At least not the Outrider I made.

Rookie_One1
Rebel Alliance
Posts: 1558
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Sun Nov 29, 2020 9:34 pm

They were set as turrets in the old patch, ah well, not like it's a big issue

Found something else, the findings I made at the time that permitted corrected turret orientation were removed, we see the default turret orientation for the YT1300, YT2000 and the falcon from the vanilla game in the current megapatch, instead of what was added before
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

User avatar
DTM
Fleet Admiral (Administrator)
Posts: 1904
Joined: Tue Apr 22, 2003 11:01 pm
Contact:

Post by DTM » Sun Nov 29, 2020 11:04 pm

Rookie_One1 wrote:
Sun Nov 29, 2020 9:34 pm
Found something else, the findings I made at the time that permitted corrected turret orientation were removed, we see the default turret orientation for the YT1300, YT2000 and the falcon from the vanilla game in the current megapatch, instead of what was added before
The original authors made no mistake when they drew the orientation of the turrets. It was intentional. The turrets are oriented this way to make the turrets' firing arc work better. In the past, having "adjusted" the orientation of the turrets was a mistake, which made it impossible to complete some original missions. We must have respect for the original authors. Before changing their work, we should investigate the reason for their decisions.

Rookie_One1
Rebel Alliance
Posts: 1558
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Sun Nov 29, 2020 11:06 pm

On my side I fixed that issue by "squarring" the fire arcs (put the same value for Y as it was for X), ah well, I can just redo it for my build
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

Rookie_One1
Rebel Alliance
Posts: 1558
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Mon Nov 30, 2020 3:38 am

Found another one !

The MC80 (Defiance model) missing it's outside hangar hardpoint, which mean that you are likely to collide when you take off after landing for reload or repairs
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

Charger116
Cadet 4th Class
Posts: 21
Joined: Sat May 12, 2012 12:31 pm

Post by Charger116 » Mon Nov 30, 2020 3:39 am

Thank you to everyone involved in putting this patch together and for all the efforts put into XWAU as a whole. It's so great to see this classic game still getting love and amazing modifications to this day.

And as others have already mentioned, this is an absolute treat in what has been a challenging year for all.

Can't wait to start my 493298th run of the campaign and test out all the amazing features (not that I need an excuse to play this gem of a game again... :D )

Rookie_One1
Rebel Alliance
Posts: 1558
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Mon Nov 30, 2020 9:40 pm

Found another bug!

Multiple craft have either wrong laser color or wrong impact color (best example I can find is the dreadnaught, for some reason it got green lasers that impact in blue
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

Avarice1987
Cadet 1st Class
Posts: 159
Joined: Fri Oct 16, 2009 9:06 pm

Post by Avarice1987 » Mon Nov 30, 2020 9:44 pm

quick question about the modpacket: i have the german language package from Darksaber, can i iron it over it, or does it chop something?

Or is there any way to change the ingame language with the modpack?


2nd question, Angel is working on a reimaged campaign of Tie Fighter

Will there be something like this in the future for the XWAU campaign? there would be something, I was asked by German users, what about the Star Viper, if it will come back in (many people think that the Star Viper is a better Black Sun fighter, because Shadows of the Empire plays parallel and the SV is used there)

Last question: In some preview videos on Yt from X Wing Facility or XWA artists I hear completely different ingame sounds ( rocket warning for example ), will there be a soundpack?

dhollinger3
Cadet 4th Class
Posts: 17
Joined: Sat May 09, 2020 3:47 am

Post by dhollinger3 » Mon Nov 30, 2020 9:51 pm

Quick question about the new X-Wing and Y-Wing Dynamic Cockpits. Why get rid of the physical MFD displays in favor of holographic ones?

I personally liked the more tactile look of the physical MFDs (they obviously don't work everywhere - like the Gunboat and Missile boat)

Regardless, I'm loving the new megapack! Great work!

I also maintain the Lutris installers for Linux users - this update has made that job significantly easier AND everything "just works" when setup with Lutris!
Last edited by dhollinger3 on Mon Nov 30, 2020 10:06 pm, edited 1 time in total.

Rookie_One1
Rebel Alliance
Posts: 1558
Joined: Thu Feb 26, 2004 12:01 am

Post by Rookie_One1 » Mon Nov 30, 2020 10:05 pm

Craft that I found with the laser color/impact color issues up to date :

Corvettes (all of them)
Modified Corvette
Dreadnaught
Assault Frigate
Nebulon-B Frigate
Escort Transport
Rookie One, is that you?? - Ru Merleen, Rebel Spy at Imdaar Alpha
Current Holder of the Frying Pan of Death

brassman2468
Cadet 4th Class
Posts: 14
Joined: Tue Jan 08, 2019 1:57 am

Post by brassman2468 » Tue Dec 01, 2020 12:53 am

Just finished B0M8, the Deep Space Strike evaluation, and was surprised to see two squadrons of TIEs in addition to the two escort shuttles protecting the final convoy. Was this an intended addition to the mission? I don't remember seeing them in previous playthroughs.

User avatar
Forceflow
Fleet Admiral (Administrator)
Posts: 6357
Joined: Wed Oct 20, 1999 11:01 pm
Contact:

Post by Forceflow » Tue Dec 01, 2020 6:31 am

brassman2468 wrote:
Tue Dec 01, 2020 12:53 am
Just finished B0M8, the Deep Space Strike evaluation, and was surprised to see two squadrons of TIEs in addition to the two escort shuttles protecting the final convoy. Was this an intended addition to the mission? I don't remember seeing them in previous playthroughs.
Those were actually included in the original mission but didn't show up due to a bug in the original mission. This was fixed so they do show up.
Murphy was an optimist! I am a pessimist!
And always remember that a smile is cheaper than a bullet! (District 9)
Webmaster of the X-Wing Alliance Upgrade Project

User avatar
Jaeven
XWAU Member
Posts: 577
Joined: Mon Mar 30, 2015 3:18 am

Post by Jaeven » Tue Dec 01, 2020 6:54 am

brassman2468 wrote:
Tue Dec 01, 2020 12:53 am
Just finished B0M8, the Deep Space Strike evaluation, and was surprised to see two squadrons of TIEs in addition to the two escort shuttles protecting the final convoy. Was this an intended addition to the mission? I don't remember seeing them in previous playthroughs.
Yes. The TIEs had always been there, they were just bugged so they never spawned. The original mission was kind of stupid because it forced you to go up against two Assault Shuttles in a Y-wing, and more often than not, your wingmate would be useless. So the Assault Shuttles were changed to Escort Shuttles, and to compensate in difficulty, the TIEs were unbugged.

dhollinger3
Cadet 4th Class
Posts: 17
Joined: Sat May 09, 2020 3:47 am

Post by dhollinger3 » Tue Dec 01, 2020 7:05 am

I found what appears to be a bug. If I set

Code: Select all

SwapJoystickXZAxes = 1
in the ddraw.cfg file, but have the `Hook_Joystick_Ff.dll` in the root of the XWA directory, then the X Axis on my joystick just stops working. If I delete, disable, or otherwise move the Joystick_Ff hook it solves the problem.

This is with the XWA2020 FixPack installed

Avarice1987
Cadet 1st Class
Posts: 159
Joined: Fri Oct 16, 2009 9:06 pm

Post by Avarice1987 » Tue Dec 01, 2020 12:13 pm

In the battles 0/3 and 0/5 (data recovery and bacta transfer with the smugglers) I always noticed with Allied Editor that attack gunboats should appear in the missions, but they didn't. Are these also old bugs or is it because of the difficulty settings?

User avatar
JeremyaFr
XWAU Member
Posts: 2985
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Tue Dec 01, 2020 2:13 pm

dhollinger3 wrote:
Tue Dec 01, 2020 7:05 am
I found what appears to be a bug. If I set

Code: Select all

SwapJoystickXZAxes = 1
in the ddraw.cfg file, but have the `Hook_Joystick_Ff.dll` in the root of the XWA directory, then the X Axis on my joystick just stops working. If I delete, disable, or otherwise move the Joystick_Ff hook it solves the problem.

This is with the XWA2020 FixPack installed
Hello,
You can try that:

EDIT: link removed
See joystick hook
Last edited by JeremyaFr on Tue Dec 01, 2020 9:43 pm, edited 1 time in total.

brassman2468
Cadet 4th Class
Posts: 14
Joined: Tue Jan 08, 2019 1:57 am

Post by brassman2468 » Tue Dec 01, 2020 3:17 pm

Jaeven wrote:
Tue Dec 01, 2020 6:54 am
brassman2468 wrote:
Tue Dec 01, 2020 12:53 am
Just finished B0M8, the Deep Space Strike evaluation, and was surprised to see two squadrons of TIEs in addition to the two escort shuttles protecting the final convoy. Was this an intended addition to the mission? I don't remember seeing them in previous playthroughs.
Yes. The TIEs had always been there, they were just bugged so they never spawned. The original mission was kind of stupid because it forced you to go up against two Assault Shuttles in a Y-wing, and more often than not, your wingmate would be useless. So the Assault Shuttles were changed to Escort Shuttles, and to compensate in difficulty, the TIEs were unbugged.
Thanks for the clarification, that makes a lot of sense. The modified mission does seem quite a bit more doable now, it only took me two tries to complete without having to resort to invulnerability. Still a bit of a challenge, but not impossible :)

EDIT: just went back and looked into the mission in YOGEME, turns out the Escort Shuttles are still Assault Shuttles just with difficulty set to Novice.

Post Reply