[Help] Shaking Screen on VR

Here you can find help for how to best run and setup your XWA VR experience.
Post Reply

[Help] Shaking Screen on VR

ttenor12
Cadet 4th Class
Posts: 10
Joined: Thu Sep 17, 2020 4:18 am

Post by ttenor12 » Thu Sep 17, 2020 4:28 am

Hey there!
I just installed all the mods, including the Effects by Blue Max's Version 1.1.4 to add VR support to the game. However, when I'm in-game, the screen shakes a lot if you move your head just a little bit, to the point where you get motion sickness after 5 minutes.

I'm thinking this is a performance issue, but I just wanted to check if this has been reported before and if there happens to be a fix. I already followed the instructions in the "Tips to Increase the Performance of the New Shaders" post, but that didn't seem to work.

My specs are:

ASUS TUFF Z390 Plus Gaming
Intel Core i5 9600K
Dual Channel 16GB Ram DDR 4 2666mhz
Nvidia GeForce RTX 2060 Super

I run the GOG version of the game and installed every single mod listed in the "Downloads" section, included the "Additional Installers" and the only mod in the "Beta versions" section. Also installed every single ship that has the "New" tag under that page.

Looking forward to a reply!

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1372
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Sep 17, 2020 6:59 pm

It's probably a performance problem. Check the "Jittering" and "Performance" sections in the following thread:

https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

I would start by lowering down the SteamVR resolution (you didn't mention that detail) and using the Deferred shader in SSAO.cfg.

ttenor12
Cadet 4th Class
Posts: 10
Joined: Thu Sep 17, 2020 4:18 am

Post by ttenor12 » Thu Sep 17, 2020 11:10 pm

blue_max wrote:
Thu Sep 17, 2020 6:59 pm
It's probably a performance problem. Check the "Jittering" and "Performance" sections in the following thread:

https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

I would start by lowering down the SteamVR resolution (you didn't mention that detail) and using the Deferred shader in SSAO.cfg.
Appreciate the response! Will give these suggestions a go.

User avatar
SoltyBadger
Recruit
Posts: 5
Joined: Thu Sep 17, 2020 12:53 pm

Post by SoltyBadger » Fri Sep 18, 2020 9:58 am

Yeah i have a similar issue, no matter how how far i lower the settings, deferred shader, set priority or steam resolution, ect. the damn shuttering that makes it unplayable for me but the game looks and runs beautifully without lag. reminds me of when i played Stormlands using virtual desktop using my quest, game runs great, looks beautiful but when you turn your head, it turns to shit.
Is there a link to the latest VR Ddraw for steamVR? maybe i don't have the latest that's why its stuttering.

User avatar
blue_max
Lieutenant Commander
XWAU Member
Posts: 1372
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Sep 18, 2020 5:06 pm

SoltyBadger wrote:
Fri Sep 18, 2020 9:58 am
Is there a link to the latest VR Ddraw for steamVR? maybe i don't have the latest that's why its stuttering.
Another thing you can try is setting your monitor's refresh rate to 60Hz if it's above that. The latest version of the VR mod and latest beta can be found in the Downloads page in this site.

User avatar
keiranhalcyon7
Lieutenant JG
Posts: 584
Joined: Tue Jan 02, 2018 6:41 am

Post by keiranhalcyon7 » Mon Oct 19, 2020 7:19 am

I find that a strangely coincidental suggestion - apparently some people have experienced stuttering issues in Squadrons VR for which the solution is "lock the frame rate to 60 fps using your GPU software".

Post Reply