[OPTing] XWA OPT Editor

Need help editing the game? Check for help here!
Post Reply

Re: [OPTing] a new opting tool is under construction

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun Feb 02, 2014 11:26 pm

To support Windows XP, I have retargeted the program to use the .Net Framework 4.0.
Now, XwaOptEditor.zip contains 2 versions:
XwaOptEditor runs on Windows 32/64 bits with the .NET framework 4.5.
(Windows Vista, Windows 7, Windows 8, or superior)

XwaOptEditor4 runs on Windows 32/64 bits with the .NET framework 4.0.
(Windows XP, Windows Vista, Windows 7, Windows 8, or superior)

Bman
Lieutenant
Posts: 915
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Mon Feb 03, 2014 8:27 am

Awesome. Thanks Jeremy! I also had trouble with the XwaOptTestTools.zip file. Those patch file tools didn't run for me either.

Question... is your XwaOptEditor basically finished, or is it a work-in-process beta release at this point? Future versions as more features added etc. ?
Last edited by Bman on Wed Feb 05, 2014 8:15 am, edited 1 time in total.
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon Feb 03, 2014 2:09 pm

I have updated XwaOptTestTools to support Windows XP.

XwaOptEditor is not a finished tool. It's a work-in-progress.

Bman
Lieutenant
Posts: 915
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Wed Feb 05, 2014 7:46 am

Thanks. Quick note, when I launch the XwaOptEditor and click the [Open] button on interface, it then crashes:
You do not have the required permissions to view the files attached to this post.
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Wed Feb 05, 2014 3:01 pm

Thanks for the bug report.
I have corrected this.

Rasalas
Cadet 2nd Class
Posts: 50
Joined: Fri Jan 17, 2014 8:09 pm

Post by Rasalas » Wed Feb 05, 2014 9:20 pm

Thank you for making your tool XP-compatible!

I've also found a bug. When trying to rename an existing file in the "Save as" window, XwaOptEditor4 crashes.
XWAOE4-Error.png
You do not have the required permissions to view the files attached to this post.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Wed Feb 05, 2014 10:25 pm

Thanks for the bug report.
I've done a small update to the SaveAs code. I don't know if it has corrected the bug.

Rasalas
Cadet 2nd Class
Posts: 50
Joined: Fri Jan 17, 2014 8:09 pm

Post by Rasalas » Thu Feb 06, 2014 12:06 am

Thanks you for your effort, but the bug is still there. The error signature is slightly different:
XWAOE4-Error2.png

Btw, when right-clicking a file in the "Open" window, the tool also crashes:
XWAOE4-Error3.png
You do not have the required permissions to view the files attached to this post.

Bman
Lieutenant
Posts: 915
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Thu Feb 06, 2014 9:04 am

This seems to be working fine for me now. GUI design looks really great, even as a beta release. Thanks Jeremy.

Rasalas, I did a "SaveAs" test and it worked for me on my .opt model. One thought, after you do your windows critical updates, go back to custom button or the windows update home page. Choose the link on far left called XP Windows "Optional Software Downloads". There are several .net framework v4 KB updates that fix stability issues and bugs. MS did not code these as O/S "Critical Updates". It might solve your stackoverflowexceptions.
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

Rasalas
Cadet 2nd Class
Posts: 50
Joined: Fri Jan 17, 2014 8:09 pm

Post by Rasalas » Thu Feb 06, 2014 1:06 pm

Bman, thanks for the tip. Unfortunately installing these .NET updates didn't solve the problem (same error codes as before).
But since the tool works fine otherwise, it isn't a big problem for me.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Wed Feb 19, 2014 9:53 pm

A small update:
added:
  • solid/wireframe display mode
  • lod selector
  • bpp warning message box if all textures have not the same bpp
AssaultFrigate.jpg
You do not have the required permissions to view the files attached to this post.

Rasalas
Cadet 2nd Class
Posts: 50
Joined: Fri Jan 17, 2014 8:09 pm

Post by Rasalas » Thu Feb 20, 2014 8:48 pm

Thanks for your continuous work Jeremy! :thumbs:

I've found another bug: I edited TG's Assault Transport and Platform 1 opts (changed some of the hardpoints from TurboEmpireLaser to SuperEmpireLaser) and after saving them nearly all laser fire will go right through them ingame. Strangely enough some lasers do hit from time to time. Probably some kind of hitzone problem?

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Fri Feb 21, 2014 12:27 am

You are right: this bug is due to the hitzone. The game engine requires the hitzone to be written in the vertex buffer.
I have corrected that.

User avatar
Marcos_Edson
Commander
XWAU Member
Posts: 2138
Joined: Fri Jan 14, 2000 12:01 am
Contact:

Post by Marcos_Edson » Sun Feb 23, 2014 4:32 pm

:2thumbs:
SETI
"There can be only one..."
"I'm an otaku! Have a problem with that?"

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Wed Mar 12, 2014 8:26 pm

An update:
added:
  • compute hitzones
  • convert textures: 8 bits <-> 32 bits
  • generate textures mipmaps
  • save / replace textures
  • add textures

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon Mar 24, 2014 7:12 pm

An update:
added:
  • split / merge meshes
  • import / export obj

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Tue Apr 29, 2014 7:01 pm

A quick update:
- updated HelixToolkit to version 2014.2.15.1

Gank
Lieutenant JG
XWAU Member
Posts: 577
Joined: Sun Mar 31, 2002 11:01 pm
Contact:

Post by Gank » Fri May 02, 2014 11:26 am

Nice work Jeremy, looks like I'll be rooting around for xwa disks this weekend

FBK
Cadet 3rd Class
Posts: 32
Joined: Sat May 18, 2013 7:05 am

Post by FBK » Fri May 02, 2014 12:34 pm

Incredible!!!
Thaks forma what you are doing

Gank
Lieutenant JG
XWAU Member
Posts: 577
Joined: Sun Mar 31, 2002 11:01 pm
Contact:

Post by Gank » Sat May 24, 2014 12:01 pm

Hi Jeremy i get an error when importing an obj
Capture.JPG
You do not have the required permissions to view the files attached to this post.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sat May 24, 2014 12:30 pm

Hi Gank,
This error means that the obj file does not contain vertex normals.

Gank
Lieutenant JG
XWAU Member
Posts: 577
Joined: Sun Mar 31, 2002 11:01 pm
Contact:

Post by Gank » Sat May 24, 2014 12:52 pm

Thanks for the quick reply, now i'm getting this error:
Capture.JPG
You do not have the required permissions to view the files attached to this post.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sat May 24, 2014 1:27 pm

I've updated XwaOptEditor to include better error messages.

Gank
Lieutenant JG
XWAU Member
Posts: 577
Joined: Sun Mar 31, 2002 11:01 pm
Contact:

Post by Gank » Sat May 24, 2014 2:56 pm

Thanks jeremy, getting a new error now, "object reference not set to an instance of an object"

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2726
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sat May 24, 2014 4:20 pm

It means that the obj file does not contain a mtllib line specifying an mtl file.
I have updated XwaOptEditor so it will not fail when an mtl file is not found. Instead, the opt file will appear in white.

Post Reply