[Help] Custom sounds not playing in game

Need help editing the game? Check for help here!
Post Reply

[Help] Custom sounds not playing in game

joey645
Recruit
Posts: 1
Joined: Tue Sep 22, 2020 8:56 am

Post by joey645 » Wed Sep 23, 2020 7:31 pm

Hello all! New here

I've been working on upgrading the sounds for the game taken from my old HQ sound mod I made for Star Wars Galaxies a few years back, figured I'd do the same for XWA. However, having an issue where sounds would not play at all when I'm in game. At first I thought maybe it was the files being stereo instead of mono, but switching them all to mono, still doesn't work.

Additionally I made sure to match the bit rate of all the original sounds (22050 hz) as well as import the sounds as .wav files (32 bit float).

Am I missing anything? Do my custom sounds need to be the same length as the original it's replacing? I know having sounds that go on for too long could potentially be cut off (due to the 32 sound per instance cap the game has).

Thanks for the help in advance!

marcop000
Cadet 2nd Class
Posts: 76
Joined: Fri Dec 27, 2019 7:08 pm

Post by marcop000 » Thu Sep 24, 2020 3:53 pm

Have you tried to export in 24 bit /44.1 Khz ? 32 bit is too match I don't think you hear the difference.

User avatar
iteachvader
Cadet 3rd Class
Posts: 45
Joined: Thu Feb 28, 2013 4:16 am

Post by iteachvader » Mon Sep 28, 2020 5:34 am

What audio editor are you using to export your sounds? If you're using Audacity, try exporting to 22050 Hz .WAV, signed 16-bit PCM. Make sure your sounds aren't too long; they don't have to be the exact length of the original.
Double check to make sure your filenames are correct as well, just in case.
The ability to create 3D models is insignificant next to the power of the Force.

Post Reply