XWAUP presents: the Super Backdrops patch

All the XWAU recent release news from the project can be found here

Re: XWAUP presents: the Super Backdrops patch

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4780
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Fri Apr 10, 2020 5:36 pm

It was all looking so good now anyway. I hope my eyes won't explode with more brilliance lol
Keep on doing that great work guys :)
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Bman
Lieutenant
Posts: 887
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Fri Apr 10, 2020 5:42 pm

Awesome. Thanks!
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

User avatar
Camerad
Cadet 3rd Class
Posts: 28
Joined: Wed Dec 25, 2013 12:07 pm

Post by Camerad » Sat Apr 11, 2020 2:56 am

Thank you.
Windows 10 Pro 64-bit, i7-10700KF, 64GB 3200MHz DDR4, Geforce RTX 2080 Super 8GB

User avatar
Jaeven
Lieutenant JG
XWAU Member
Posts: 563
Joined: Mon Mar 30, 2015 3:18 am

Post by Jaeven » Sat Apr 11, 2020 4:48 am

Great job!

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4780
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun Apr 19, 2020 9:46 pm

I've been doing a fresh reinstall and I may have encountered a small bug but you also just explained it I think. Best make sure so it's clear.
I installed the XWAUP which has the first SBP in. Then I installed this 2.1 patch. I lost everything in 3d except the HUD. So no hangar no ships just stars lol
I've gone back to normal now and I'm going to install the effects etc and cockpits, see if that works then come back to the Patch.
Just trying to see if there's an order of installation needed.

EDIT: Ok so I redid everything and did the 2.1 Patch last. It seems ok now. Not sure if it's because of the order I did it in or just a glitch.
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4780
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Mon May 04, 2020 2:43 pm

SUPER BACKDROPS PATCH V2.1. By DTM with Darksaber.

Image

Version 2.1 comes with new starfield backdrops and explosions effects. It is an update that improves all the backdrops, taking advantage of the JeremyaFr Hooks, which allow the use of 32-bit transparent images. Basically, the planets no longer have the black outline and blend better with the star background. No changes to missions, no new unpublished images, only a huge leap in quality!

It's already been released but the news post highlights it again :)
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Bman
Lieutenant
Posts: 887
Joined: Mon Apr 05, 2004 11:01 pm

Post by Bman » Tue May 05, 2020 12:41 am

Thanks Ace for clarifying that. This is the same installer released around April 10, 2020. Nothing new since then. :-) Have an idea, might be good to put the latest release date on each download link or at least in the readme.txt files. That might be helpful for some peeps.
W-I-P: ISD-II, XQ-1 Platform1, (Imp) Escort Carrier, Misc, & TFTC.

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4780
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Tue May 05, 2020 12:56 am

Bman wrote:
Tue May 05, 2020 12:41 am
Thanks Ace for clarifying that. This is the same installer released around April 10, 2020. Nothing new since then. :-) Have an idea, might be good to put the latest release date on each download link or at least in the readme.txt files. That might be helpful for some peeps.
All downloads now have version numbers. So if you have downloaded this again then it would have tried to overwrite the existing version you had.
This release never got a proper news post. That's why it has now to promote it
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
AngeI
Cadet 1st Class
Posts: 137
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Sun May 17, 2020 3:59 pm

Hi, I've noticed a problem with this update I think. The explosion effects aren't working too well, particularly I noticed this on torpedoes. Although they show up at near point blank range, when you destroy them a bit further out, no explosion effect appears so the torpedo itself essentially just vanishes. Same thing once they impact a target, the explosion effect just isn't there unless you're right up close. I restored an older explosions.dat file from the backup and it works fine again.

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2657
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Sun May 17, 2020 4:45 pm

Hello,
You can try to install the latest hooks with XwaHooksSetup.

User avatar
AngeI
Cadet 1st Class
Posts: 137
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Sun May 17, 2020 5:24 pm

I tried this but didn't make a difference :(

User avatar
DarHan
Cadet 1st Class
Rebel Alliance
Posts: 248
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Sun May 17, 2020 5:36 pm

I actually have the same problem, even with all hooks up to date. All explosions except for the largest ones become invisible beyond ~1km.
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4780
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun May 17, 2020 5:40 pm

AngeI wrote:
Sun May 17, 2020 3:59 pm
Hi, I've noticed a problem with this update I think. The explosion effects aren't working too well, particularly I noticed this on torpedoes. Although they show up at near point blank range, when you destroy them a bit further out, no explosion effect appears so the torpedo itself essentially just vanishes. Same thing once they impact a target, the explosion effect just isn't there unless you're right up close. I restored an older explosions.dat file from the backup and it works fine again.
Have you restored to Super Backdrops v2.0?
So does it only happen on the updated Super Backdrops v2.1 release?
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
AngeI
Cadet 1st Class
Posts: 137
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Sun May 17, 2020 6:35 pm

Ace Antilles wrote:
Sun May 17, 2020 5:40 pm
Have you restored to Super Backdrops v2.0?
So does it only happen on the updated Super Backdrops v2.1 release?
Yes this works fine on v2.0 if I revert (assuming DSUCP 2.6 is using 2.0 of this). Simply replacing the explosions.dat with the backed up version and they work fine again. I used the v2.1 EXE installer to do the upgrade.

User avatar
Darksaber
Vice Admiral
Posts: 10932
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Sun May 17, 2020 8:41 pm

Solved it

One reason I updated the explosions was to take advantage of Jeremys 32 bit hook, he updated the XwaDatEditor to use type 25
JeremyaFr wrote:
Sun Jul 21, 2019 7:09 pm
Without the 32-bit mode hook, the game treats type 24 and 25 the same way.
With the 32-bit model hook and with XwaDatEditor, the type 25 is 32-bit.
- Format 7:
Format: 8-bit indexed colors and 1-bit alpha, rle compressed.
Use: concourse or in-flight.

- Format 23:
Format: 8-bit indexed colors and 8-bit alpha, rle compressed.
Use: concourse.

- Format 24:
Format: 8-bit indexed colors and 8-bit alpha.
Use: in-flight.

- Format 25:
Format: 32-bit ARGB.
Use: in-flight.
There is no limit for DAT images.
While creating the Explosions.Dat I set everything to Type 25.

I've just converted the images to Type 24, and guess what the explosions show up

You can download the updated Link Removed Extract the files and copy and paste then test
“You can please some of the people all of the time, you can please all of the people some of the time, but you can’t please all of the people all of the time”.”
- John Lydgate

Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
Ace Antilles

Admiral (Moderator)
Posts: 4780
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun May 17, 2020 10:01 pm

Darksaber wrote:
Sun May 17, 2020 8:41 pm
Solved it

One reason I updated the explosions was to take advantage of Jeremys 32 bit hook, he updated the XwaDatEditor to use type 25

While creating the Explosions.Dat I set everything to Type 25.

I've just converted the images to Type 24, and guess what the explosions show up

You can download the updated Link Removed Extract the files and copy and paste then test
Hadn't seen the error but thanks for the quick fix :)
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

User avatar
Vince T

Fleet Admiral (Administrator)
Posts: 12930
Joined: Fri Apr 27, 2001 11:01 pm
Contact:

Post by Vince T » Sun May 17, 2020 11:03 pm

Now that I see the explosions again, I know what I had actually missed ! Great work and thank you!
Your ship, Captain. I need a drink. - Vince Trageton

My Steam Workshop

User avatar
DarHan
Cadet 1st Class
Rebel Alliance
Posts: 248
Joined: Mon Dec 05, 2005 12:01 am
Contact:

Post by DarHan » Mon May 18, 2020 12:50 am

Yup, I confirm that this new file fixes the issue on my end.
“Red Four, nothing’s gone wrong yet.”
— Hobbie Klivian

User avatar
AngeI
Cadet 1st Class
Posts: 137
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Mon May 18, 2020 7:22 am

Also confirmed, all seems to be working normally now, thanks guys :)

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2657
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon May 18, 2020 12:45 pm

Hello,
Can you try that:

EDIT: link removed
Last edited by JeremyaFr on Mon May 18, 2020 1:43 pm, edited 1 time in total.

User avatar
Darksaber
Vice Admiral
Posts: 10932
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Mon May 18, 2020 1:03 pm

Tried it with the Type 25 Explosion.dat, the explosion don't show until you get within 0.20km at 1km there is just a small impact that's hardly noticeable

EDIT: with type 24 at 1km you see the explosions clearly
“You can please some of the people all of the time, you can please all of the people some of the time, but you can’t please all of the people all of the time”.”
- John Lydgate

Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2657
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon May 18, 2020 1:05 pm

Please retry.
I've just updated the hook.

User avatar
Darksaber
Vice Admiral
Posts: 10932
Joined: Mon Jan 10, 2000 12:01 am
Contact:

Post by Darksaber » Mon May 18, 2020 1:10 pm

That got it! type 25 is now a GO!

Image

Tried it a 2k and I could clearly see the explosions

Thanks Jeremy
“You can please some of the people all of the time, you can please all of the people some of the time, but you can’t please all of the people all of the time”.”
- John Lydgate

Good Things Come To Those Who Wait....
Darksaber's X-Wing Station

User avatar
JeremyaFr
Commander
XWAU Member
Posts: 2657
Joined: Mon Jan 18, 2010 5:52 pm
Contact:

Post by JeremyaFr » Mon May 18, 2020 1:43 pm

Hello,
I've merged the changes into the stable version.

User avatar
AngeI
Cadet 1st Class
Posts: 137
Joined: Sun Jan 24, 2016 5:27 pm

Post by AngeI » Mon May 18, 2020 4:40 pm

Also working fine for me now since the hook update. Thanks :)

Post Reply