[B4M1] Battle 4 - Mission 1: Shipment to Mining Colony (Family mission)

Here we can have in-depth discussions about which missions need to be adjusted because they are broken either by original design or by XWA models.
Post Reply

[B4M1] Battle 4 - Mission 1: Shipment to Mining Colony (Family mission)

El Giggi
Recruit
Posts: 4
Joined: Tue Jul 14, 2020 10:17 am

Post by El Giggi » Tue Jul 14, 2020 10:57 am

Dear XWA upgrade Team,
I usually a passive reader since I heard of your amazing mod most recently. Then I saw this forum section that fits perfectly with some problems I encountered. Most of these have already been addressed by other threads here but I haven't found any information on this particular mission yet.
Its the Mission where you raid a Space Station and steal containers for the Alliance. You are flying with a wing of friendly fighters. Its mostly straight forward, but at one point, usually when all the ships (the freighters with cargo, the fighters and yourself) arrive at the asteroid base one of the allied escort fighters starts destroying the freighters leading to a mission failure.
This betrayal can also happen already at the enemy space station. This happens without any warning in either dialog or mission tab update. So Im pretty sure its a bug.
It seems there is a timer in the background and after a certain amount of time (which i couldn't determine) at least one of the escorts turns on the freighters.

I tried the mission in all difficulty modes and the result is always the same, with now exception. It's weird that I haven't read about this anywhere else, because it happens to me every time.

For the mods im using:
XWA craft pack 1.6
Rebel Dynamic Cockpits 2.1
Blue Max 1.1.3.2
Super backdrops 3.0

Hope you can help me with that, I managed to get by the mission by turning all freighters invincible, but that's not a satisfying solution.
Last edited by Forceflow on Tue Nov 03, 2020 5:41 pm, edited 1 time in total.
Reason: Title Adjusted

User avatar
Forceflow
Fleet Admiral (Administrator)
Posts: 6472
Joined: Wed Oct 20, 1999 11:01 pm
Contact:

Post by Forceflow » Tue Jul 14, 2020 11:12 am

Mhm, that is strange. I played that mission a couple of days ago but didn't have that happen. Jaeven also did not report any issues with that mission.
Jaeven wrote:ping
Any idea what could cause this?
Last edited by Ace Antilles on Tue Jul 14, 2020 12:27 pm, edited 1 time in total.
Reason: Fixed quote
Murphy was an optimist! I am a pessimist!
And always remember that a smile is cheaper than a bullet! (District 9)
Webmaster of the X-Wing Alliance Upgrade Project

User avatar
Jaeven
XWAU Member
Posts: 578
Joined: Mon Mar 30, 2015 3:18 am

Post by Jaeven » Wed Jul 15, 2020 12:44 am

No idea what could cause this. There's nothing in the orders that would cause this to happen.

Try replacing the mission file in your missions folder with the file I've uploaded and tell me if it still happens.
You do not have the required permissions to view the files attached to this post.

El Giggi
Recruit
Posts: 4
Joined: Tue Jul 14, 2020 10:17 am

Post by El Giggi » Wed Jul 15, 2020 8:59 pm

Hey Jaeven, I just tested the mission with your mission file again and this time in worked as intended. No treacherous Starfighters this time. Thanks.


I attached my old mission file. If you are curious maybe you can check out if there is anything odd with it. I opened it in a mission editor but couldn't find anything obvious.
You do not have the required permissions to view the files attached to this post.

Luke_Skywalker
Cadet 1st Class
Posts: 146
Joined: Fri Mar 11, 2005 12:01 am

Post by Luke_Skywalker » Thu Dec 10, 2020 2:52 pm

New issue with B4M1. Lara 2 spontaneously exploded next to one of the Medium Transports. I'm pretty sure it collided with one of them since nothing was shooting at it. This mission is cursed: you lose almost all of your wingmen when the Viraxo jump in, the Charybdis fairly easily can make short work of the conveyor transports, the Supa fighters in the Vergesso area all go for you so you lose a lot of shield very quickly, and now mission-critical ships exploding when they're supposedly safe is back.

[EDIT] The cause may actually be Juno 4 colliding somehow with Lara 2, because on a third playthrough Juno 4 narrowly avoided a collision by what looked like inches.
When 900 years old you reach, look as good, you will not. Hmm?" -Yoda

GABICV
Cadet 3rd Class
Posts: 30
Joined: Wed Mar 17, 2021 1:47 pm

Post by GABICV » Thu May 06, 2021 4:00 pm

I have a similar issue as @Luke_Skywalker and can't get to pass this mission. Freighters are just randomely getting destroyed once they arrive in the Vergesso area. And I'm not lucky enough to be able to complete the mission before it happens (I tried probably 5 or 6 times).

Usually by the time I'm done dealing with the 4 Supa fighters in the zone at least 1 freighter exploded, sometimes 2 or 3. It's never the same one so I did not yet manage to be close to one while it explodes to see what happens. But I assume it collides with an asteroid or something.

I'm playing on a Steam install, with Mega Update and patch 3.0. Don't know if the new asteroids could be a factor in this.

Blazingfirestorm
Cadet 1st Class
Posts: 158
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Thu May 06, 2021 4:41 pm

yep your right the freighters are crashing into each other it might need them spitting up there FG I'll test a few things

looking at it I think if you change where they are coming out of hyperspace in region 2 so that don't crash into each other should fix it

Blazingfirestorm
Cadet 1st Class
Posts: 158
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Fri May 07, 2021 1:03 am

I come up with a fix and I tested it three times so it should work but if it doesn't someone please tell me
1B4M1FB.TIE
@Ace Antilles
You do not have the required permissions to view the files attached to this post.
Last edited by Blazingfirestorm on Sun May 09, 2021 11:21 pm, edited 1 time in total.

GABICV
Cadet 3rd Class
Posts: 30
Joined: Wed Mar 17, 2021 1:47 pm

Post by GABICV » Fri May 07, 2021 12:47 pm

Hey @Blazingfirestorm thanks a lot, your mission file works just fine. No more stupid freighter destroying itself carelessly.

Just one thing I noticed: One of the Razor fighters (#47-2) that arrives with the Viraxo convoy when you are in the Viraxo area decided to just fly away with no question asked and was impossible to get to. The consequence of this is that the Azzameen escort fighters went after him once all the other fighters were down and therefore never hypered to the Vergesso area.
I didn't see this behavior with the original mission file so I guess it's a consequence of the changes you made. I didn't try to fly the mission again to see if it's repeatable.

Anyway, good job!

Blazingfirestorm
Cadet 1st Class
Posts: 158
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Fri May 07, 2021 1:03 pm

Hi @GABICV thanks for the feed back I had a look at the FG RZR/F Gundark 4 and I didn't change it so don't know why you experienced that behaviour FG TOS/F Secforce won't hyper until all starfighters in Region 4 are destroyed but that's OG behaviour
Last edited by Blazingfirestorm on Fri May 07, 2021 6:47 pm, edited 1 time in total.

GABICV
Cadet 3rd Class
Posts: 30
Joined: Wed Mar 17, 2021 1:47 pm

Post by GABICV » Fri May 07, 2021 4:04 pm

OK then I'm not sure why this happened.
Not a big deal anyway; just a slightly higher challenge to deal with the 4 Supa Fighters at the Vergesso base on your own.

Blazingfirestorm
Cadet 1st Class
Posts: 158
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Fri May 07, 2021 4:32 pm

well FG TOS/F Secforce don't help in Vergesso region anyway their orders are to escort the freighters not attack Supa Fighters, I mean if have 200% shields when you go into that region the player should fine

User avatar
Ace Antilles
Admiral (Moderator)
Posts: 5957
Joined: Sat Jan 22, 2000 12:01 am
Contact:

Post by Ace Antilles » Sun May 09, 2021 12:44 am

Blazingfirestorm wrote:
Fri May 07, 2021 1:03 am
I come up with a fix and I tested it twice so it should work but if it doesn't someone please tell me
1B4M1FB.TIE
@Ace Antilles
Please can you elaborate on exactly which ships you have changed and how. Thanks
Chief XWAU Team annoying nitpicker.
Ace Antilles - The X-Wing Outpost
Image

Blazingfirestorm
Cadet 1st Class
Posts: 158
Joined: Sat Dec 09, 2017 9:39 pm

Post by Blazingfirestorm » Sun May 09, 2021 1:09 am

sure the two FG's in question are FG Juno 1 and FG Juno 4 I've change the position that they hyper out at in region 4 so that when they arrive in region 2 they don't crash into each other as to how I did it is I changed their way point on their hyper to region 2 order in region 4

Post Reply