[Help] Shaking Screen on VR

Here you can find help for how to best run and setup your XWA VR experience.
Post Reply

[Help] Shaking Screen on VR

ttenor12
Cadet 4th Class
Posts: 10
Joined: Thu Sep 17, 2020 4:18 am

Post by ttenor12 » Thu Sep 17, 2020 4:28 am

Hey there!
I just installed all the mods, including the Effects by Blue Max's Version 1.1.4 to add VR support to the game. However, when I'm in-game, the screen shakes a lot if you move your head just a little bit, to the point where you get motion sickness after 5 minutes.

I'm thinking this is a performance issue, but I just wanted to check if this has been reported before and if there happens to be a fix. I already followed the instructions in the "Tips to Increase the Performance of the New Shaders" post, but that didn't seem to work.

My specs are:

ASUS TUFF Z390 Plus Gaming
Intel Core i5 9600K
Dual Channel 16GB Ram DDR 4 2666mhz
Nvidia GeForce RTX 2060 Super

I run the GOG version of the game and installed every single mod listed in the "Downloads" section, included the "Additional Installers" and the only mod in the "Beta versions" section. Also installed every single ship that has the "New" tag under that page.

Looking forward to a reply!

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Sep 17, 2020 6:59 pm

It's probably a performance problem. Check the "Jittering" and "Performance" sections in the following thread:

https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

I would start by lowering down the SteamVR resolution (you didn't mention that detail) and using the Deferred shader in SSAO.cfg.

ttenor12
Cadet 4th Class
Posts: 10
Joined: Thu Sep 17, 2020 4:18 am

Post by ttenor12 » Thu Sep 17, 2020 11:10 pm

blue_max wrote:
Thu Sep 17, 2020 6:59 pm
It's probably a performance problem. Check the "Jittering" and "Performance" sections in the following thread:

https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

I would start by lowering down the SteamVR resolution (you didn't mention that detail) and using the Deferred shader in SSAO.cfg.
Appreciate the response! Will give these suggestions a go.

User avatar
SoltyBadger
Recruit
Posts: 5
Joined: Thu Sep 17, 2020 12:53 pm

Post by SoltyBadger » Fri Sep 18, 2020 9:58 am

Yeah i have a similar issue, no matter how how far i lower the settings, deferred shader, set priority or steam resolution, ect. the damn shuttering that makes it unplayable for me but the game looks and runs beautifully without lag. reminds me of when i played Stormlands using virtual desktop using my quest, game runs great, looks beautiful but when you turn your head, it turns to shit.
Is there a link to the latest VR Ddraw for steamVR? maybe i don't have the latest that's why its stuttering.

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Sep 18, 2020 5:06 pm

SoltyBadger wrote:
Fri Sep 18, 2020 9:58 am
Is there a link to the latest VR Ddraw for steamVR? maybe i don't have the latest that's why its stuttering.
Another thing you can try is setting your monitor's refresh rate to 60Hz if it's above that. The latest version of the VR mod and latest beta can be found in the Downloads page in this site.

User avatar
keiranhalcyon7
Lieutenant JG
Posts: 586
Joined: Tue Jan 02, 2018 6:41 am

Post by keiranhalcyon7 » Mon Oct 19, 2020 7:19 am

I find that a strangely coincidental suggestion - apparently some people have experienced stuttering issues in Squadrons VR for which the solution is "lock the frame rate to 60 fps using your GPU software".

pandabacon
Recruit
Posts: 2
Joined: Thu Oct 22, 2020 5:09 pm

Post by pandabacon » Sat Oct 24, 2020 5:14 am

I have the same issue in STEAMVR where the game is running well until you move your head then its just jitters. If I don't move my head the game is smooth and has zero lag. I have a 1080ti and have no issues with other VR games like Squadrons for example I run at 150% SS Resolution in SteamVR with no issues. Non VR this game runs super smooth as well.

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sun Oct 25, 2020 5:28 am

pandabacon wrote:
Sat Oct 24, 2020 5:14 am
I run at 150% SS Resolution in SteamVR with no issues. Non VR this game runs super smooth as well.
What is the per-eye resolution you're trying in SteamVR? You may have to lower it down a bit. As a reference, I play at 960x1080 with an nVidia 1060. The resolution is a bit low, but it's playable.

BatSpoggy
Recruit
Posts: 2
Joined: Fri Jun 14, 2019 12:58 pm

Post by BatSpoggy » Sun Nov 01, 2020 9:49 am

Hi blue_max, I tried the new version and this mod has come a long way since the one I tested a while back. The performance issues I was getting back then seem to be totally solved and so is the weird cockpit warping.
I am getting the cockpit juddering effect described here, and it's not a performance issue because I'm now getting very good framerates. It's like the headtracking from SteamVR needs a bit of a smoothing filter on it. The effect is a bit like something is vibrating your head. I tried turning cockpit inertia off to see if that was contributing to it, but it didn't make any difference.
I can't get over how well this is running now, it's fantastic!

BatSpoggy
Recruit
Posts: 2
Joined: Fri Jun 14, 2019 12:58 pm

Post by BatSpoggy » Sun Nov 01, 2020 10:12 am

Just to follow up, I found that setting active cockpit off reduced the jittering to a level that's really not noticeable anymore. For the benefit of anyone reading, in the Active_Cockpit.cfg set the option active_cockpit_enabled = 0. Setting the in-game resolution option to 640x480 with HUD 1.0 might have also helped a little, but the increase in HUD size was the main help there.

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Nov 12, 2020 9:30 pm

Thanks for posting this, BatSpoggy. Yes, the Active Cockpit is known to cause some jittering, this is an area that needs some optimization.

CharlieD
Recruit
Posts: 3
Joined: Thu Dec 03, 2020 2:45 am

Post by CharlieD » Thu Dec 03, 2020 3:09 am

Hello folks,

After finding out about this website, and discovering it has a VR Mod capability, I just installed the Nov 2020 MegaPack and the first upgrade patch, and gave it a shot (using a Valve Index, i7-8700, 16GB RAM, GTX1070Ti, and the game is on Steam).
The initial start-up gave me no VR, and I couldn't find within the Babu Frik (?) option on how to enable VR (this was only an option to disable the 'Blue Effect' (?)).
I was able to enable VR by "open VRParams.cfg and set "VR_Mode" to "SteamVR" and in CockpitLook.cfg you need to make sure "tracker_type" is set to "SteamVR".
I, too, am experiencing the jitter when turning my head, and if I understand BatSpoggy correctly, disabling the Active Cockpit is the best chance to reduce the jitter.

Because of my newfound 'noob' mentality in trying out the game, is there any other VR basic hints I should be aware of?
(I'm currently having multiple issues in controlling the game through both the keyboard/mouse or a Xbox One Wireless Controller, but I'll place that in the 'Help' area of the forum)

Thanks in advance for any insight/help that can be provided.

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Dec 03, 2020 8:19 pm

CharlieD wrote:
Thu Dec 03, 2020 3:09 am
I, too, am experiencing the jitter when turning my head, and if I understand BatSpoggy correctly, disabling the Active Cockpit is the best chance to reduce the jitter.
This has helped a lot of users, yes.
Because of my newfound 'noob' mentality in trying out the game, is there any other VR basic hints I should be aware of?
Take a look at this thread: https://www.xwaupgrade.com/phpBB3/viewt ... 36&t=12827

Basic things: Make sure your video card is being used by the game (press Esc, check the name of the video card in the Video Settings menu). Start with a low SteamVR resolution and use the Deferred shader in SSAO.cfg.

CharlieD
Recruit
Posts: 3
Joined: Thu Dec 03, 2020 2:45 am

Post by CharlieD » Fri Dec 04, 2020 9:05 pm

Thank you for the feedback.

Post Reply