Terrible shaking on headset display, but not on desktop [SOLVED]

Here you can find help for how to best run and setup your XWA VR experience.
Post Reply

Terrible shaking on headset display, but not on desktop [SOLVED]

Spriggs
Recruit
Posts: 2
Joined: Thu Nov 19, 2020 6:46 pm

Post by Spriggs » Wed Dec 30, 2020 11:07 pm

First post here guys - thanks for such a wonderful mod to bring new life to my favorite old game.

Following the advice previously posted on other threads here, I managed to boot up XWA with my Vive Pro. Got it to run flawlessly! However...

I seem to have encountered a type of variant of the common shaking/stuttering problem, where the game becomes almost unplayable when moving your head. While standing still, there is no issue. I've tried multiple solutions found for this problem - shaders, resolutions, active cockpit, etc. - with no change. But then I noticed something. And this is the interesting part...

The problem exists only in the headset itself, not on the computer.
So, let's say I'm sitting and using the headset in game. To my eyes, there is horrible choppiness and stuttering. But if you were to watch over my shoulder as I played, the display on the screen would be smooth as butter, and you would never know what I'm experiencing. The game does not lag or stutter at all when viewed on my desktop. I.e., when I take my headset off, and view the game thru the steamvr display, the motion is perfect. Essentially, I could play the game with smooth motion by holding the headset in my hands to look around and watching the screen. Eliminates all chop.
This leads me to believe it is some sort of issue within the display of the headset itself. That is an issue I have not been able to find in the various threads here - hence my new post.

I am running the new Mega install patch on a Razer 15 with no discernible performance issues whatsoever. My headset is a Vive Pro.

Any advice? Thanks much.

Spriggs
Recruit
Posts: 2
Joined: Thu Nov 19, 2020 6:46 pm

Post by Spriggs » Thu Dec 31, 2020 5:29 am

For the record for anyone else experiencing this same issue, I found a solution. I managed to dredge up a buried post from Nuttyapprentice in which he graciously and tactfully posted his modifications, creating a solution that - for me, anyway - worked. So I'll repost it here in hopes that maybe it will for someone else too.
Life-changing experience now that I can play it proper! This project is amazing.

Nuttyapprentice:

Nvidia Control Panel:
Low Latency Mode -ON (limits number of frames the CPU can prepare before sending to the GPU, this had a huge effect on the jitters for me)
Max Frame Rate -90fps
Texture Filtering -Quality -Perfomance
Vsync -Off

SteamVR:
Per app settings:
Resolution is personal pref, im on Vive-Pro and got it working fine on 111%
Motion Smoothing - Off (I enabled it in VR params below)

XWA Config:
VRParams.cfg: SteamVR_Interleaved_Reprojection = 1
Bloom.cfg: Bloom_levels = 5
Active_Cockpit.cfg: Active_Cockpit_enabled = 0
DDraw.cfg: EnableMultisamplingAntialiasing = 0
EnableFXAA = 0
EnableAnisotropicFiltering = 1
SSAO.cfg: ssao_type = Deferred
samples = 6
max_dist = 120
speed_shader_max_particles = 180

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Thu Dec 31, 2020 11:37 pm

Hello Spriggs. Great job figuring this out! I don't think anyone had reported that the motion was only jittering in the display. I think the fix is in the Low Latency Mode and VSync settings. I'm going to link to your post from the main SteamVR troubleshooting thread.

Again, thanks for sharing this

HanSolo77
Recruit
Posts: 9
Joined: Sat Jun 20, 2020 4:44 pm

Post by HanSolo77 » Fri Jan 08, 2021 12:44 pm

Hi everybody,

I am having the same problem.

I am using a Pimax 8K-X, and as long as I don't move my head, movement is okay and smooth enough at around 25-30 FPS.
As soon as I start moving my head, I get jitter in the HMD. Whereas the movement on the monitor mirror stays smooth as if everything was fine.

I already changed my settings according your advice, @Spriggs , and it does get a little better, but not significantly enough to get a smooth flight.

In contrary:
I made the NVidia Control Panel changes to a separate alliance.exe-profile I created - and it works far better compared to changing the standard general NVidia profile to the settings above...:
When leaving my NVidia general 3D settings on my "defaults":
- low latency mode -OFF
- Max Frame Rate -OFF
- Texture Filtering Quality -High Quality
- VSync -ON

and making the adjustments in the alliance.exe-profile
- low latency mode -ON
- Max Frame Rate -75
- Texture FQ -Performance
- VSync -OFF

=> then I just get a bit of jitter and judder, and it is ... well... "playable"... though not fully enjoyable.
Whereas when writing those settings directly into the general profile, the jitter and judder just gets so terrible the game gets unplayable and I'd get motion sick in short time although I am used to VR since four or five years now.

Of course, I also made the adjustements in the according config-files.
Turning on Pimax Smart Smoothing doesn't change anything.

I'd be glad for any deeper investigation or support :)

Thx already,
HanSolo77

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Fri Jan 08, 2021 8:08 pm

HanSolo77 wrote:
Fri Jan 08, 2021 12:44 pm
I made the NVidia Control Panel changes to a separate alliance.exe-profile I created
Thanks for sharing your setup. I've got a question, though. There are two executables in the XWA directory: Alliance.exe (the launcher) and xwingalliance.exe (the game itself). I think you should create a profile for xwingalliance.exe, not for the launcher. Can you try that?

Also, did you disable the Active Cockpit (just checking)?

Finally: the shaking only happens inside the headset, correct? Motion is still smooth on the screen?

HanSolo77
Recruit
Posts: 9
Joined: Sat Jun 20, 2020 4:44 pm

Post by HanSolo77 » Sat Jan 09, 2021 9:57 am

Hi,

thanks for your answer.

Okay, I followed your advice and switched the NVidia settings to xwingalliance.exe:
I get the same really bad and unplayable results as if I set these settings to the general profile. First, terrible jitter und juddering, second FPS going down in quarter room already from constant 30 to 25, third CPU frametimes increasing from "green" (0.4-1ms) to "red" (~30ms).

So, as a result from both trials and your clarification of the difference between launcher- and game.exe, it seems as if I get better results with my NVidia general default settings, not applying @Spriggs changes, instead of setting those values either to the general or xwingalliance.exe profile...
Quite a bit strange.

Just for summary and double-check:
- Antialiasing Mode: determined by App
- Antialiasing Transparency: OFF
- FXAA: OFF
- Max. FPS: 75
- Low Latency mode: ON (not ULTRA!)
- Texture Filtering Quality: Performance (not High Performance!)
- VSync: OFF


Coming back to your other questions:
- Active_cockpit_enabled is set to "0" = disabled
- And yes, shaking / jitter / judder only inside the HMD itself. Smooth motion on the screen.


Appendix:
Here are my personal "default" NVidia general profile settings with which, paradoxically, I get better and more playable results:
- Antialiasing Mode: determined by App (same)
- Antialiasing Transparency: Multisample
- FXAA: OFF (same; I generally don't like FXAA - makes the whole image more blurry)
- Max. FPS: OFF
- Low Latency mode: OFF
- Texture Filtering Quality: High Quality
- VSync: ON

Next, I'll try to figure out which of these settings is making things worse.
Nevertheless, remains the question which settings make things even better and really enjoyable ;)

HanSolo77
Recruit
Posts: 9
Joined: Sat Jun 20, 2020 4:44 pm

Post by HanSolo77 » Sat Jan 09, 2021 10:26 am

I now made a couple of trials with different settings.

In my case, setting "Low Latency mode" to OFF is the culprit: As long, as it is set to ON, I have light judder/shaking/jitter, a bit annoying, but somewhat playable. As soon as I set it to OFF, I get really terrible, motion sickness creating judder when moving my head.

Further observations:
- Antialiasing Transparency: OFF => Multisample => no influence
- Texture Filtering Quality: Performance => High Quality / High Performance => no influence
- VSync: OFF => ON / Fast => no influence
- Changing In-game resolution: 1920x1080 => 1024x768 => no influence/hardly noticeable

Furthermore:
- Activating active cockpit: "0" => "1" => no influence

So, first, Low Latency Mode must be turned OFF for me, and as @Spriggs mentioned, the difference is really huge - but ironically in the other direction for me ;)
Second, there must be some other, second root cause for the judder inside the HMD I was not able to determine until now.


For info the most important and problem related spec's of my PC:
Ryzen 5 5600X
Gigabyte RTX 3080 Gaming OC
16 GB RAM
Kingston A2000 1TB m2-SSD
Windows 10 Pro 64bit 20H2, all up-to-date
NVidia 460.89

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Sun Jan 10, 2021 12:42 am

@HanSolo77 Well, I don't know if this will help, but I just noticed that I've got SteamVR configured to run with nVidia in the nVidia Control Panel as well. These are the binaries I added:

C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrcompositor.exe
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrmonitor.exe

The only thing I did was select "Run with High-Performance nVidia Processor". Another thing you can try is to increase the priority of both xwingalliance.exe, vrmonitor.exe and vrcompositor.exe. I feel your problem is related to tracking, but I'm not sure why. If there's another VR-related process you might try increasing its priority as well.

HanSolo77
Recruit
Posts: 9
Joined: Sat Jun 20, 2020 4:44 pm

Post by HanSolo77 » Mon Jan 11, 2021 8:07 am

Hi @blue_max :)

I did configure something like that already in the Windows Extended Graphic Settings, but just noticed, Windows did remove the entries... :? Ironically, it was Windows itself which already added VRDashboard there; I just added xwingalliance.exe and put both to maximum performance.
Windows... :irre:

But I will follow your advice and configure both SteamVR-exe in the NVidia Control Panel just as you mentioned.

The problem seems to be related to tracking only, indeed. On Saturday, I made a lot of other setting-trials with the different xwaup-config files, but achieved no further improvement. Except, when turning off (head)tracking in CockpitLook.cfg (tracker_type = SteamVR => tracker_type = None): Then, everything is "fine" - but I have no headtracking any more at all ;)

I am just thinking about whether to install my old TrackIR just for testing purpose and give it a try. If it worked well with this one, then we would know for sure it is related to SteamVR-tracking. But I admit: I just set up a clean Windows install before X-Mas, and as I don't use my TrackIR any more since I am playing in VR, I originally did not plan to install anything to my new Windows I don't need... ;)

I first will try it once again with your NVidia settings.

Thanks for your support :thumbs:

HanSolo77
Recruit
Posts: 9
Joined: Sat Jun 20, 2020 4:44 pm

Post by HanSolo77 » Mon Jan 11, 2021 8:18 am

Okay, I just noticed, that I don't have this option in my NVidia Control Panel :?
I already checked Google and found someone stating, this could happen if Windows installs the drivers - but I have removed the Windows NVidia installation the first day already and replaced it with a clean and full install of 460.89. Still, I cannot see that option anywhere.

The only things I did now, are
- Energy mode: Maximum performance prefered (or how it is called in English version)
- VSync: OFF, already there

User avatar
blue_max
XWAU Member
Posts: 1598
Joined: Wed Mar 20, 2019 5:12 am

Post by blue_max » Mon Jan 11, 2021 8:40 am

HanSolo77 wrote:
Mon Jan 11, 2021 8:18 am
Okay, I just noticed, that I don't have this option in my NVidia Control Panel :?
Which option are you referring to? If you're talking about the process priority, you do that through the Task Manager. Right click on the process -> Go to Details -> Right Click again -> Set Prority.

HanSolo77
Recruit
Posts: 9
Joined: Sat Jun 20, 2020 4:44 pm

Post by HanSolo77 » Mon Jan 11, 2021 10:37 am

This one:
Well, I don't know if this will help, but I just noticed that I've got SteamVR configured to run with nVidia in the nVidia Control Panel as well. These are the binaries I added:

C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrcompositor.exe
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrmonitor.exe

The only thing I did was select "Run with High-Performance nVidia Processor".
=> This used to be an option in the NVidia Control Panel when adding manually apps, between point "1." (App list) and "3." (3D settings).
This option is missing for me - I don't have it, and "3". gets "2."

Post Reply